Unifi Lite-6

    Install OpenWRT

    Through ssh, normally the device get an ip through dhcp

    1. scp openwrt-21.02.5-ramips-mt7621-ubnt_unifi-6-lite-squashfs-sysupgrade.bin ubnt@192.168.10.151:/tmp
    2. Update environment:
    fw_setenv devmode TRUE
    fw_setenv boot_openwrt "fdt addr \$(fdtcontroladdr); fdt rm /signature; bootubnt"
    fw_setenv bootcmd "run boot_openwrt"
    
    1. Check everything is set: fw_printenv
    2. Check the mtd partition number for bs / kernel0 / kernel1 cat /proc/mtd
    3. Set the bootselect flag to boot from kernel0 dd if=/dev/zero bs=1 count=1 of=/dev/mtdblock4
    4. 4 minutes flashing dd if=/tmp/openwrt-21.02.5-ramips-mt7621-ubnt_unifi-6-lite-squashfs-sysupgrade.bin of=/dev/mtdblock6 dd if=/tmp/openwrt-21.02.5-ramips-mt7621-ubnt_unifi-6-lite-squashfs-sysupgrade.bin of=/dev/mtdblock7
    5. reboot took 3 minutes until having a solid blue line
    6. connect the ap directly to the computer since it runs a DHCP server and distribute an ip by default you need to switch as a dhcp client

    Note: default user ubnt, default password ubnt

    source

    Files

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA256
    
    3aaa6dad59dfbe77016fb32f9dcba6a552049aff7d7023d5cd1324c63a24c20f  openwrt-21.02.5-ramips-mt7621-ubnt_unifi-6-lite-squashfs-sysupgrade.bin
    -----BEGIN PGP SIGNATURE-----
    
    iHUEAREIAB0WIQS6FrUxin3X0/uI3zRD+jfzTY+N4AUCY4Oe+wAKCRBD+jfzTY+N
    4KV0AQCGgTinqXe72ihLu8ghiRF4qpkHD5pefkkCvi+HKomqzgD6AnEQZ+IuPjsj
    KQNwhC98b/TcA/Mc1u8f3yFtUCIk8NE=
    =IJzS
    -----END PGP SIGNATURE-----
    

    Here are some to set-up mesh with batman on OpenWRT 21.02.5 available in [misc/mesh-packages-mt7621]:

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA256
    
    7cae1a9625293ff62deba72b01c675c33f2b60fd3efb088bb549f3620286bb6a  batctl-full_2021.1-2_mipsel_24kc.ipk
    0d79f4786928116918080639f3f8bed05ecc61bba4527dd4d9dc220029ccf01b  batctl-tiny_2021.1-2_mipsel_24kc.ipk
    7f987ddde6ba7ffce73d8e2a7645070ffdf213458d4863aae58f9eba18c34ebb  kmod-batman-adv_5.4.215+2021.1-9_mipsel_24kc.ipk
    8d6ba211492df3f1098916d747186fe492347fd9627b6551ab89e7c0edb0f0e0  kmod-crypto-crc32c_5.4.215-1_mipsel_24kc.ipk
    ae0ea70b1a3bf7809575e6ffd1677c71aaa1117866cddbeeced1dd4e119d020d  kmod-crypto-hash_5.4.215-1_mipsel_24kc.ipk
    d7f8c72f3eb7995b419bd778d9c33b914ef0bb04a983dc1d44a93f2f4413ea37  kmod-lib-crc16_5.4.215-1_mipsel_24kc.ipk
    fe7b7975dc749c7e483dfc885f60375d681d302c0e79b637ad409566e75a168b  kmod-lib-crc32c_5.4.215-1_mipsel_24kc.ipk
    b0fc937c8836d55cc3cddbb540032236591b3f58032dcd78351b57bc29898171  libopenssl1.1_1.1.1q-1_mipsel_24kc.ipk
    5234f0645b26a7a6595fcd8673da8f2529f36bce2c3929e36252a8c7ba8e5a19  librt_1.1.24-3_mipsel_24kc.ipk
    637bfef497e1b58adb61065d65e0f96e6936f0ea0e1917447bc5102b07163a35  wpad-mesh-openssl_2020-06-08-5a8b3662-41_mipsel_24kc.ipk
    -----BEGIN PGP SIGNATURE-----
    
    iHUEAREIAB0WIQS6FrUxin3X0/uI3zRD+jfzTY+N4AUCY4O57QAKCRBD+jfzTY+N
    4JrlAPwLbCd4I9UZ1oCIDAdIMqN1QZU1yEAPOulANq4QJ4ckpwD+Nkj8smZ2UwQc
    Cdnt0d4ltkLLTHYBa9JOENwi7ElmPu8=
    =q7kd
    -----END PGP SIGNATURE-----
    
    

    Default Wifi Configuration

    /etc/config/wireless (from openwrt 22.03.2)

    config wifi-device 'radio0'
            option type 'mac80211'
            option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
            option channel '1'
            option band '2g'
            option htmode 'HT20'
            option disabled '1'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'lan'
            option mode 'ap'
            option ssid 'OpenWrt'
            option encryption 'none'
    
    config wifi-device 'radio1'
            option type 'mac80211'
            option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
            option channel '36'
            option band '5g'
            option htmode 'HE80'
            option disabled '1'
    
    config wifi-iface 'default_radio1'
            option device 'radio1'
            option network 'lan'
            option mode 'ap'
            option ssid 'OpenWrt'
            option encryption 'none'
    
    

    Default network configuration

    /etc/config/network

    config device
    	option name 'br-lan'
    	option type 'bridge'
    	list ports 'lan'
    	option stp '1'
    	option igmp_snooping '1'
    	option mtu '2304'
    
    # lan
    config interface 'lan'
      option device 'br-lan.100'
      option proto 'static'
      option netmask '255.255.255.0'
      option ipaddr '192.168.2.10'
      option ipv6 '0'
    	option gateway '192.168.2.1'
      list dns '192.168.2.227'
    	option force_link 'yes'
    

    Led Color Pattern

    source

    Recovery (Ubiquiti OS)

    1. push reset during 20sec+, wait blinking state (blue, white, black, blue, white etc.)
    2. ip address add 192.168.1.25/24 dev enp0s31f6 && ip route add default via 192.168.1.20
    3. tftp
    4. In case the ip is not 192.168.1.20, you can find it by looking with tcpdump -i enp0s31f6 arp
    connect 192.168.1.20
    binary
    rexmt 1
    timeout 60
    put BZ.mt7621_5.60.23+13051.211209.2348.bin
    
    1. reboot and wait ~5 minutes

    BZ.mt7621_5.60.23+13051.211209.2348.bin